ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Files encoded with 10.2, which loader version is required?

Author Message
eugenio



Joined: 05 Feb 2016
Posts: 9

PostPosted: Tue Jun 12, 2018 12:14 pm    Post subject: Files encoded with 10.2, which loader version is required? Reply with quote

Hello,
I've encoded a script with ioncube 10.2; a client is telling me that he gets this message:

"the file ... is corrupted".

The file is NOT corrupted so I guess the problem is with the loader; from his phpinfo I see:

with the ioncube loader (enabled) + intrusion protection ... (unconfigured) v 10.0.3

so I guess his version is 10.0.3. Isn't it enough to read a script encoded with version 10.2?

Thanks.
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 371

PostPosted: Tue Jun 12, 2018 4:26 pm    Post subject: Reply with quote

Hi,

If you have used the bundled encoding feature, which in the GUI is the "5.6 & 7.1" source language option, then the client will have to upgrade the Loader as the 10.0.3 Loader will not understand the bundled encoding. Indeed, the 10.0.3 Loader would output an "is corrupted" message if it encounters a bundled encoding file.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
eugenio



Joined: 05 Feb 2016
Posts: 9

PostPosted: Tue Jun 12, 2018 5:35 pm    Post subject: Reply with quote

alastair wrote:
Hi,

If you have used the bundled encoding feature, which in the GUI is the "5.6 & 7.1" source language option, then the client will have to upgrade the Loader as the 10.0.3 Loader will not understand the bundled encoding. Indeed, the 10.0.3 Loader would output an "is corrupted" message if it encounters a bundled encoding file.


Thanks for the information.
Yes, I've used the bundled encoding. Which version of the loader is requested exactly?

Is there a way to understand, when you encrypt, which is the minimum version of the loader required? I think the whole thing is quite confusing.
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 371

PostPosted: Thu Jun 14, 2018 8:18 am    Post subject: Reply with quote

Hi,

If you encode without bundling or using the 7.2 Encoder then any version 10 Loader, starting from 10.0 should run the files.

If you use bundling then a version 10.1 or later Loader should work.

If you use 7.2 encoding then you will need a version 10.2.x Loader for PHP 7.2.

In all cases, however, it is best to upgrade to the latest Loader available.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
eugenio



Joined: 05 Feb 2016
Posts: 9

PostPosted: Thu Jun 14, 2018 9:00 am    Post subject: Reply with quote

alastair wrote:
Hi,

If you encode without bundling or using the 7.2 Encoder then any version 10 Loader, starting from 10.0 should run the files.

If you use bundling then a version 10.1 or later Loader should work.

If you use 7.2 encoding then you will need a version 10.2.x Loader for PHP 7.2.

In all cases, however, it is best to upgrade to the latest Loader available.


Ok, I understand. The thing is pretty complicated so my question is: is there a way to know, when we encode, which loader version our users will need? We can't ask every time on the forum!

People rely on their hosting providers and not all the hosting providers always upgrade the loaders to the last version (actually I think a minority do it).
Back to top
View user's profile Send private message
eugenio



Joined: 05 Feb 2016
Posts: 9

PostPosted: Wed Jun 20, 2018 8:58 am    Post subject: Reply with quote

Any news?
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 371

PostPosted: Wed Jun 20, 2018 10:12 am    Post subject: Reply with quote

Hi,

Apologies for the delay in replying. However, it is better to ask for detailed support by creating a ticket in our Support Help Desk at https://support.ioncube.com

I am not sure quite what you mean by your question, "is there a way to know, when we encode, which loader version our users will need?" The algorithm for determining the minimum Loader version when encoding with the version 10 Encoder is as I stated in my previous reply i.e.

- If you encode without bundling (the 5.6 & 7.1 option in the GUI) or using the 7.2 Encoder then any version 10 Loader, starting from 10.0 should run the files.

- If you use bundling when encoding then a version 10.1 or later Loader should work.

- If you use 7.2 encoding then you will need a version 10.2.x Loader for PHP 7.2.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
eugenio



Joined: 05 Feb 2016
Posts: 9

PostPosted: Wed Jun 20, 2018 12:29 pm    Post subject: Reply with quote

Cases 1 and 3 seem in contrast to me, you said:

- If you encode without bundling (the 5.6 & 7.1 option in the GUI) OR using the 7.2 Encoder then any version 10 Loader is OK

from this sentence, I assume that if I use the 7.2 encoder any 10.x loaders is ok, but then you said:

- If you use 7.2 encoding then you will need a version 10.2.x Loader for PHP 7.2.

I don't understand.

My question, in general, was related to the ability to understand autonomously (without asking here) which version loader do we need.

You explained some rules but what is going to happen with the next ioncube version? Probably something is going to change ... getting a simple message, when you encode a project, that says EXACTLY which loader version you need seems a pretty basic feature to me!
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 371

PostPosted: Thu Jun 21, 2018 9:02 am    Post subject: Reply with quote

Hi,

What I meant in case 1 was that if you do not use bundling and do not use the 7.2 Encoder then any version 10 Loader would be fine. So the "without" in the original sentence applied to both sides of the "or".

Generally, when a new major version of the Encoder is released a new Loader is released at the same time or slightly before as that new Loader version will be required to run the new encoded files. However, the new Loader will also run files from previous versions of the Encoder.

With regard to the Encoder saying which Loader version is required, that may be more tricky than it seems at first sight. For example, generally encoded files produced with respect to some source language will run on later PHP versions with an appropriate Loader installed. However, that Loader version would typically only have been released long after the Encoder was produced. For example, the first full release of a Loader for PHP 7.2 was version 10.1.0 in December 2017 which allowed files produced by the 10.0 Encoder, released in August 2017, to run on PHP 7,2.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
eugenio



Joined: 05 Feb 2016
Posts: 9

PostPosted: Wed Jun 27, 2018 1:06 pm    Post subject: Reply with quote

I understand there could be cases when, for a particular PHP version, the loader is not ready yet ... but for all the other cases my question remains: how can we tell our customers which are the minimum ioncube requirements (at least for the PHP version supported at that moment) to use our software ?
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 371

PostPosted: Thu Jul 05, 2018 2:07 pm    Post subject: Reply with quote

Hi,

Wasn't your question covered by my previous answers with regard to the Loader version? Please could you say what case was not covered?
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum