ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Help with run/installation of iOnCube

Author Message
BlueWorker



Joined: 18 Mar 2014
Posts: 1

PostPosted: Tue Mar 18, 2014 11:32 am    Post subject: Help with run/installation of iOnCube Reply with quote

I have a problem with the iOnCube Loader.

My localhost have:
Apache: 2.4.6
PHP: 5.5.3-1ubuntu2.1

my phpinfo() is saying that the Loader is loaded successful
Quote:
with the ionCube PHP Loader v4.5.3, Copyright (c) 2002-2014, by ionCube Ltd.


Downloaded loaded-wizard.php also said that everything is ok:
Quote:
Loader Installed

The ionCube Loader version 4.5.3 for PHP 5.5 is already installed and encoded files should run without problems.


But... I have a problem with PhotoStore script.

While installing I'm getting the error:
Code:
Fatal error: The file /home/szymon/webs/wildcard/imagescript/source/public/dev/assets/ioncube/ioncube-encoded-file.php was encoded by the ionCube Encoder for PHP 4 and cannot run under PHP 5.5. Please ask the provider of the script to provide a version encoded with either the ionCube Encoder for PHP 5.3 or for PHP 5.4. in Unknown on line 0

or
Code:
Fatal error: The file /home/szymon/webs/wildcard/imagescript/source/public/devs/assets/includes/enc.functions.php was encoded by the ionCube Encoder for PHP 5 and cannot run under PHP 5.5. Please ask the provider of the script to provide a version encoded with either the ionCube Encoder for PHP 5.3 or for PHP 5.4. in Unknown on line 0


The script is ok, because right now I installed it on production server (with PHP 5.4) and everything is ok.


What's wrong with my local environment ?
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Wed Mar 19, 2014 1:26 am    Post subject: Reply with quote

This is because the script was encoded to run on a very old version of PHP, and cannot be run on PHP 5.5. Code produced for PHP 5.3 upwards can run on PHP 5.5, so if the script provider can deliver an updated script then that should work fine. It can be run on PHP 5.4 however.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum