ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Incompatible loader / encoder versions

Author Message
swervedriver



Joined: 23 Jan 2014
Posts: 1

PostPosted: Thu Jan 23, 2014 1:04 pm    Post subject: Incompatible loader / encoder versions Reply with quote

Hi There,

I have a client who has loader version 4.2.2 installed. Their host has upgraded their php version to 5.4.21.

I have provided encoded files for php 5.4, their error log gives the following:

'The file /path/to/file.php cannot be decoded by this version of the ionCube Loader.'

I think there was something about major level 3 and needed to be 5.

What is the best resolution? I have suggested that the host might like to update the loader file. Is there an alternative combo of encoding that I can supply that will work if their host refuses?

Thanks Question
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Sat Feb 08, 2014 1:29 pm    Post subject: Reply with quote

Loader 4.4.0 released May 2013 was when we introduced support for running files encoded specifically for PHP 5.4, hence the error that the user sees. The host should upgrade to the latest Loaders, currently 4.5.2.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum