ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Goto page 1, 2  Next
 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

ioncube for php 5.5

Author Message
mohamed.xcoder



Joined: 08 Nov 2013
Posts: 1

PostPosted: Fri Nov 08, 2013 11:53 pm    Post subject: ioncube for php 5.5 Reply with quote

Hello ,

i install php 5.5 on mac os 10.9

but the ioncube not working with me .

please help me how to downgrade to php 5.4 " i using xampp on mac os 10.9 " or how to get ioncube work on php 5.5

thank you
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Sat Nov 09, 2013 4:49 pm    Post subject: Reply with quote

Please note that the PHP 5.3 and 5.4 languages are still being developed and are not downgrades, they are simply different variations of the language.

It's best to contact the providers of xampp as they should be able to advise on this, and as updates for 5.4 in particular are still being released, they should be able to provide a suitable package for you.
_________________
Community Admin
Back to top
View user's profile Send private message
gregtampa



Joined: 06 Dec 2013
Posts: 1

PostPosted: Fri Dec 06, 2013 8:46 pm    Post subject: Kawashi and Reply with quote

still waiting been 3 months.
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Sat Dec 07, 2013 12:44 am    Post subject: Reply with quote

Our Loader for running PHP 5.3 and PHP 5.4 encoded files with the PHP 5.5 language on Linux, OS X and FreeBSD is currently due to be released this coming week!
_________________
Community Admin
Back to top
View user's profile Send private message
lowprofile



Joined: 12 Dec 2013
Posts: 2

PostPosted: Thu Dec 12, 2013 5:33 pm    Post subject: 9628684234 Reply with quote

liaison wrote:
Our Loader for running PHP 5.3 and PHP 5.4 encoded files with the PHP 5.5 language on Linux, OS X and FreeBSD is currently due to be released this coming week!



Hi

This weeks is near ending Smile Any plan to release it tomorrow?
We are a lot of people desperate waiting for this release....

Thanks!
Back to top
View user's profile Send private message
thekrynn



Joined: 27 Jul 2010
Posts: 8

PostPosted: Fri Dec 13, 2013 1:50 pm    Post subject: Reply with quote

Seconded. Been eagerly waiting to upgrade a large software solution we've developed in house but can't start as we need to easily migrate to Ubuntu 13.10 on over 2 dozen VMs.
Back to top
View user's profile Send private message AIM Address
alastair



Joined: 23 Feb 2010
Posts: 371

PostPosted: Fri Dec 13, 2013 5:13 pm    Post subject: Reply with quote

Version 4.5 loader packages are now available from our Loaders Page (http://www.ioncube.com/loaders.php) and include loaders for PHP 5.5.

As previously mentioned, the PHP 5.5 loaders will run PHP 5.3 and PHP 5.4 encoded files and are available for Unix-style platforms such as Linux, OS X and FreeBSD. Windows loaders will follow in due course.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
thekrynn



Joined: 27 Jul 2010
Posts: 8

PostPosted: Fri Dec 13, 2013 8:30 pm    Post subject: Reply with quote

Thanks guys... MUCH appreciated!
Back to top
View user's profile Send private message AIM Address
thekrynn



Joined: 27 Jul 2010
Posts: 8

PostPosted: Sat Dec 14, 2013 9:35 am    Post subject: Reply with quote

Hey guys,

Got it up and running. 4.5 Loader works great on all my OS X and Linux systems running php 5.3. Then, I went to try it on my laptop running OS X 10.9 with php 5.4 and also on my test ubuntu 13.10 VM running php 5.5, and both are segfaulting when I attempt to run php files.

This is happening when I encode my files using the ioncube53 encoder. When I use the ioncube5 (which I have been until today), it works on all machines except the ubuntu php 5.5 machine (which told me to use a minimum of the iobcube53 encoder)

Any ideas?

-----
Update: Started stripping apart files and trying random code and it looks like a fairly random problem. Was able to get a file that's 2 lines long to segfault, and then literally take away the line break or random spaces to get it to work fine, so it's not a code execution problem...
Back to top
View user's profile Send private message AIM Address
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Sat Dec 14, 2013 12:17 pm    Post subject: Reply with quote

As code is compiled to a different language during encoding, whitespace etc. in original source has no impact. If you have unexpected behaviour please create a support ticket as we'll definitely want to take a look.
_________________
Community Admin
Back to top
View user's profile Send private message
snowtr



Joined: 12 Dec 2013
Posts: 1
Location: Canada

PostPosted: Mon Dec 16, 2013 4:59 pm    Post subject: Reply with quote

This fixed my Logzilla installation.

Thanks,
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Mon Dec 16, 2013 10:34 pm    Post subject: Reply with quote

Great, glad that it's working for you.
_________________
Community Admin
Back to top
View user's profile Send private message
kwbrown524



Joined: 17 Dec 2013
Posts: 1

PostPosted: Wed Dec 18, 2013 12:05 am    Post subject: ioncube for php 5.5 Reply with quote

alastair wrote:
As previously mentioned, the PHP 5.5 loaders will run PHP 5.3 and PHP 5.4 encoded files and are available for Unix-style platforms such as Linux, OS X and FreeBSD. Windows loaders will follow in due course.


Thanks for the update! Can we have some kind of rough estimate about how long it will be until the Windows version 4.5 Loader is released?
Back to top
View user's profile Send private message
lowprofile



Joined: 12 Dec 2013
Posts: 2

PostPosted: Wed Dec 18, 2013 3:03 pm    Post subject: 54522639 1529 Reply with quote

Awesome! Working smoothly without any issues! [PHP 5.5]

Thanks a lot!

[Captha check not working correctly on your forum]
Back to top
View user's profile Send private message
natostanco



Joined: 19 Dec 2013
Posts: 1

PostPosted: Thu Dec 19, 2013 1:55 pm    Post subject: Reply with quote

What should I do with this error?
Quote:
[...].php was encoded by the ionCube Encoder for PHP 5 and cannot run under PHP 5.5. Please ask the provider of the script to provide a version encoded with either the ionCube Encoder for PHP 5.3 or for PHP 5.4. in Unknown on line 0
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum