ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

executor_globals

Author Message
horsebiz



Joined: 06 Feb 2006
Posts: 1

PostPosted: Mon Feb 06, 2006 10:24 pm    Post subject: executor_globals Reply with quote

I am having a problem with a new server.
I was getting this message when I tried to use WHMXtra.
The file /usr/local/cpanel/whostmgr/docroot/themes/x/tools.php has been encoded with the ionCube PHP Encoder and requires the free ionCube PHP Loader to be installed.

After reinstalling the ioncube loader, the page I wanted to see in WHMXtra just came up blank.

It appears that there is an issue with the loader itself as the following error shows in the logs when apache is restarted.

Failed loading /usr/local/ioncube/ioncube_loader_lin_4.3.so:
/usr/local/ioncube/ioncube_loader_lin_4.3.so: undefined symbol:
executor_globals.

I have reinstalled the loader several times from different uploads and it is still not working. Is there something else I should do?

Server Info
WHM 10.8.0
Cpanel 10.8.1-R113
CentOS 4.2 x86_64
Zend has been installed.

From usr/local/zend/etc.php.ini

[Zend]
zend_extension = /usr/local/ioncube/ioncube_loader_lin_4.3.so

zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-2_6_2
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-2_6_2
zend_optimizer.version=2.6.2

zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so


I did use the download from http://downloads.ioncube.com/loader_..._x86-64.tar.gz
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Mon Feb 06, 2006 11:50 pm    Post subject: Reply with quote

The usual problem here is building PHP with --enable-versioning. This typically prevents export of symbols from the PHP engine API, preventing engine modules from being linked. Rebuild PHP without --enable-versioning and if you're still stuck create a helpdesk ticket and we'll advise further.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum