ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Still can't get encoded files to work .. .

Author Message
elex



Joined: 31 Jan 2006
Posts: 4

PostPosted: Sat Feb 04, 2006 12:55 pm    Post subject: Still can't get encoded files to work .. . Reply with quote

Hi all ,

This shouldn't be so difficult I think! I understand now what these loaders do and have followed all instructions for run-time-loading. I've also tried the ioncube-loader-helper.php and it told me in green letters that the encoded files can be used.

After this i've checked with the developers of the application I am trying to install and they've 'repaired' my licensing details. They say it should work in my root directory and any directory under it. So I placed my aplpication in :
ROOT/APPLICATION in order to acces my install.php file.

But still I get the following message : The encoded file /root/application/install/install.php is not permissioned for MY IP ADRES (wich is correct)..

I am not even getting replies anymore from the application developers...
Anyone know's what is wrong, or anyone experienced this before ? Maybe I am doing something wrong still ?

Elex
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Sat Feb 04, 2006 1:24 pm    Post subject: Reply with quote

Hi, Encoded files themselves are clearly working as you get a message to say that they're not permissioned. You only get that message if the Loaders are installed.

The message about not being permissioned indicates that the restrictions applied to the files, or that are contained in a license file, are not met by your machine. This could be because the IP address is wrong, or because you are not accessing the scripts via the same domain that the scripts are restricted for. This is easy to check. Firstly ask the providers of the scripts to tell you what details they locked your scripts to. This will be information that you provided them in the first place. Then check that you are running the scripts on the same setup. Assuming that the scripts are locked to both IP address and server name (domain name), $_SERVER['SERVER_ADDR'] or $_SERVER['LOCAL_ADDR'] and $_SERVER['SERVER_NAME'] should match the details that they used. You can verify those with either a PHP script to echo those variables or a phpinfo script. You'll find that info on a phpinfo page near the bottom.

If you're still stuck, create a ticket in the helpdesk and send us a link to a phpinfo page and one of the encoded files, and we can see whether the details match up or not.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum