ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Issues with Zend debugger and ionCube Loader

Author Message
leason



Joined: 21 Oct 2005
Posts: 2

PostPosted: Fri Oct 21, 2005 3:18 pm    Post subject: Issues with Zend debugger and ionCube Loader Reply with quote

We are using the Modern Bill system which comes encoded with Ion Cube. Everything worked fine for a while until the other day when we had to install Zend studio (3.5) on the server in order to do some debugging. After we installed Zend studio we started getting this error:
Quote:
<path removed>/billing/include/functions.inc.php cannot be processed because an untrusted PHP zend engine extension is installed. Read more about this message

Now, like I said, this was working properly before. However, I tried to resolve this issue by adding the ioncube loader to our php.ini file as the instructions indicate. I do this before any Zend studio directives. This had no effect on the problem.

I was also able to verify another problem between Zend and Ioncube that was mentioned in another thread; that you cannot have the debugger and ioncube running on the same box. Once I removed our office IP from the list of allowed connections in the debugger lines the server started behaving again, but did not resolve the problem described above.

I am able to access the loader-helper file and it says everything is fine. I can also view the encoded-file and it displays fine. But when I go back out and try to load modern bill I get that error every time.

Any ideas?

-Lee
Back to top
View user's profile Send private message
leason



Joined: 21 Oct 2005
Posts: 2

PostPosted: Fri Oct 21, 2005 3:35 pm    Post subject: Reply with quote

Okay, I talked to ioncube support (they were extremely helpful, btw)

The deal is that the debugger cannot be on the same machine as ioncube's loader regardless of whether you have it in the php.ini file or are using it in the load at runtime fashion.

I have tested and confirmed that simply removing the Zend debugger info from my php.ini file makes the ioncuber loader work properly, re-adding re-breaks it. So the bottom line is that they cannot work together. You have to encode your files with the option to allow it to run with untrusted extensions. Unfortunately that is not an option for me because modernbill is not my problem, but they do offer a Zend encoded version so we'll have to switch to that.

Hope this helps someone!

-Lee
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum