ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Error message after installing ioncube loader

Author Message
Tommy100



Joined: 15 Oct 2005
Posts: 2

PostPosted: Sat Oct 15, 2005 9:09 pm    Post subject: Error message after installing ioncube loader Reply with quote

After i installed the ioncube loader (first line in the php.ini) i get the following message:
Code:
[ionCube Loader] The Loader must appear in the php.ini file before other extensions

There is no code in the php.ini befor the install line for the loader so why do i get this message?

OS: Gentoo Linux (hardened)
Server: Apache 2.0.54
php: 4.4.0

Any Suggestions?
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Sat Oct 15, 2005 10:22 pm    Post subject: Reply with quote

Either there is another extension installed before and you missed it, or your system is setup so that PHP is parsing the php.ini file twice. php.ini file handling is PHP is flawed in several respects, and one of these is that PHP may parse the php.ini file twice, if for example the php.ini directory is also one of the additional scan directories, and it's not smart enough to know that it's rereading the same file. If you can't figure out the problem from this, please create a helpdesk ticket and send us a link to a phpinfo file.
_________________
Community Admin
Back to top
View user's profile Send private message
Tommy100



Joined: 15 Oct 2005
Posts: 2

PostPosted: Sun Oct 16, 2005 6:34 pm    Post subject: Reply with quote

The ionCube Loader seems to not work with hardenedphp. Trying with normal php works. Is there a way to have it work with hardenedphp?
(hardenedphp is a compile Flag in Gentoo Linux)
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Mon Oct 17, 2005 12:22 am    Post subject: Reply with quote

Hi

The opensource hardened PHP patch changes the PHP internals so as to make it non-standard, and incompatible with extensions built for the official PHP distribution. At this time we do not produce separate Loaders for non-standard PHP builds. It might be best if the patch becomes adopted by the PHP group as standard.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum