ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Error message after uploading...

Author Message
veturi



Joined: 31 Oct 2005
Posts: 1

PostPosted: Mon Oct 31, 2005 8:53 am    Post subject: Error message after uploading... Reply with quote

Hello,
I just copied the Loader to my webserver, but I only get this message:
Parse error: parse error in /home/htdocs/xxx/html/agile/ioncube-loader-helper.php on line 363
I tried the same in ioncube-directory, but same error...
another testprogram gives this infos:
Quote:

Testing whether your system has ionCube Loader in php.ini...Failed
Testing whether your system has Zend Optimizer in php.ini...Failed
Testing whether your system can load ionCube Loader dynamically...Failed (extension_dir setting in php.ini is incorrect - points to not-existing folder)
Testing results:
Unfortunately, no available loaders found in your system and some additional configuration required. Please contact your hosting support and ask them to do ONE from the following:
Disable PHP safe_mode;
OR
Install free Zend Optimizer
OR
Install free ionCube Loader
Additional information: PHP version 4.3.4 (apache2handler)
OS Linux a15176279 2.6.9-041214 #1 SMP Tue Dec 14 01:56:52 CET 2004 i686
safe_mode Disabled
enable_dl Enabled
extension_dir /usr/lib/php/extensions
PHP Extensions xml, posix, openssl, apache2handler, snmp, ldap, pgsql, zlib, yp, xslt, wddx, odbc, sysvshm, sysvsem, swf, sockets, shmop, readline, qtdom, mysql, mime_magic, mhash, mcrypt, mcal, mbstring, imap, iconv, gmp, gettext, gd, ftp, filepro, exif, domxml, dbase, dba, curl, ctype, calendar, bz2, bcmath
CURL binary Not found, but curl PHP extension is available


Anyone an idea whats's happening? Embarassed
Thanks...
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Mon Oct 31, 2005 11:28 am    Post subject: Reply with quote

Hi

Firstly it looks like you have a corrupted, and also possibly and old, version of the Loader helper script. Line 363 should read

if($_rd[$_i]=='/') {

The other script you used came from the software provider, It shows that Zend Optimiser isn't installed, which is the usual case and it isn't required anyway, and that the host hasn't configured their machine correctly for dynamic install of our Loader to be possible. The extension folder needs to exist for dynamic install to work. If you have a dedicated server, then the best thing is to just install the Loader into the php.ini file as this gives the best performance. Otherwise, if you have a shared server, ask the host to either install the Loader for you, or if they create the extension directory, then dynamic install may then be possible.

If you're still stuck, please create a ticket in the helpdesk and we can assist further. The provider of the scripts should also be able to help you of course.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum