ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Help with compatability issue

Author Message
apwindjammer



Joined: 19 Jan 2005
Posts: 1

PostPosted: Wed Jan 19, 2005 8:00 pm    Post subject: Help with compatability issue Reply with quote

Hello all, I'm very much an amateur, but I'm forced to figure out a problem with my site. I'm running a shopping cart script by litecommerce.com and just like that, it doesn't work right. I keep getting this error: Fatal error: Class xlite: Cannot inherit from undefined class object in
/home/karmel/public_html/shop/var/run/classes/XLite.php on line 47

The help at litecommer.com said it was a compatability issue and to download and install the recent ioncube loader for windows. I did that and there's no change. My site is http://www.karmelctry.com/shop/cart.php if you want to look.

Can anyone please help me understand what is going on here?

Thanks

Wayne
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Thu Jan 20, 2005 11:36 pm    Post subject: Reply with quote

Hi

We also picked this up in your support ticket, and we're getting in touch with XCart about this. There's no known Loader issue or reports of issues with other applications from customers with the 4.3 Loader, and it's many months since the 4.3 Loader came out when PHP hit 4.3.0, but we're following this through just in case. Hopefully XCart will get back to us so we can work with them on this.

Nick
--
ionCube Support
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Fri Jan 21, 2005 10:55 am    Post subject: Reply with quote

After checking with X-Cart, it seems that this issue is just as a result of the exceptional changes that happened in 4.3.10, and they confirmed that the new Loader did resolve this. Perhaps the new Loader didn't get installed for some reason.

To be sure, please take the latest Loaders for Win32 from the Loaders page and let us know via the support system if you still have problems.

Nick
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum