ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

ionCube Loader 2.4 incompatibility???

Author Message
chris_bel



Joined: 20 Apr 2005
Posts: 2

PostPosted: Wed Apr 20, 2005 10:55 am    Post subject: ionCube Loader 2.4 incompatibility??? Reply with quote

After installing the Loader on my xampp (www.xampp.de), entering the loader into the php.ini and restarting my apache, I receive the following error message:

eAccelerator 0.9.2a is incompatible with the ionCube PHP Loader 2.4

I have already re-installed the loader but there are no changes...! Sad


Can anyone help me?


thx


chris
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Wed Apr 20, 2005 11:35 am    Post subject: Reply with quote

Hi Chris

This is an mmcache/EA problem, not a Loader problem, and there's no fundamental incompatibility as such. We had a patch for mmcache that fixed mmcache, and the EA developers should be able to produce one for EA.

Btw., the latest Loaders are release 2.5, so you might want to get the latest to be up to date.

Whilst on the topic of opensource extensions in general, EA and others fall into a category that we call "untrusted" extensions. This is because they're opensource, and could be used as a potential starting point for would-be hackers trying to tinker with the PHP internals at runtime. In reality, this risk is pretty unlikely, but none the less, the Encoder has a feature whereby encoded files can be protected from running in an environment where such extensions are installed. With the pre version 5 Encoders, this protection was the default, but with release 5, the Encoder user must choose to add this protection when they encode their files. If you have scripts that report as not being able to run because an untrusted extension is installed, then it means that the script provider had the protection applied, quite possibly by default, when they encoded. In such a situation, either remove the opensource "untrusted" extension, or ask the script provider to provide scripts that permits such extensions.
_________________
Community Admin
Back to top
View user's profile Send private message
chris_bel



Joined: 20 Apr 2005
Posts: 2

PostPosted: Wed Apr 20, 2005 1:46 pm    Post subject: Reply with quote

Thx for this fast answer.

For the moment, awaiting a solution, I have deactivated the eacc and activated the zend.


Thx!


chris
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum