ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Encoded Website not loading

Author Message
etienne



Joined: 24 Sep 2020
Posts: 3

PostPosted: Thu Sep 24, 2020 10:24 am    Post subject: Encoded Website not loading Reply with quote

Hi, I'm trying ioncube PHP encoder to see how it works before buying it.
The result is for now: it is not working.
I installed ioncub loader, it is well done as >php -v prints :
Code:
PHP 7.1.9 (cli) (built: Aug 30 2017 18:34:46) ( ZTS MSVC14 (Visual C++ 2015) x64 )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader v10.4.3, Copyright (c) 2002-2020, by ionCube Ltd.

and loader_wizard says:
Code:
Loader Installed
The ionCube Loader version 10.4.3 for PHP 7.1 is already installed and encoded files should run without problems.


I encode my project without error. But when I go to the website, the browser is just waiting indefinitely and the page is not displayed.

I simplified my project until keeping a single index.php containing

Code:
<?php
echo "write and exit";

And the result is the same.
Please help me make it working or I will need to find another solution.
Thank you
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 378

PostPosted: Thu Sep 24, 2020 4:47 pm    Post subject: Reply with quote

Hi,

Please create a ticket in our Support Help Desk about this at https://support.ioncube.com

In your ticket please attach the full phpinfo for the Windows system, on which you are running the encoded files. Please attach that as a single HTML file.

Please also attach your encoding project file (.iep file) to the ticket.

It would also be a good idea to check the PHP error log to see if any errors are logged there. Please paste any such errors into the ticket.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
etienne



Joined: 24 Sep 2020
Posts: 3

PostPosted: Fri Sep 25, 2020 8:39 am    Post subject: Reply with quote

It's done, thank you for the advice.
Back to top
View user's profile Send private message
etienne



Joined: 24 Sep 2020
Posts: 3

PostPosted: Fri Sep 25, 2020 4:15 pm    Post subject: The explanation Reply with quote

After several tests on two computers, the problem was I used PHP 7.2 to encode a project but ran it in PHP 7.1.
The second computer displayed directly the error message explaining the reason of the problem, whereas the first computer was waiting for nothing to append (and it never happened so the browser kept waiting).

So if this happen to you, check the PHP version, even if no error message invites you to do so.
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 378

PostPosted: Mon Sep 28, 2020 7:55 am    Post subject: Reply with quote

If no error message is appearing then it may be that display_errors is set to off in the PHP configuration. However, if log_errors is on then some error should be recorded in either the PHP error log (if error_log is set) or the web server's error log (if error_log is not set).
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum