ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Loader no longer working using PHP 7.3

Author Message
martijnbolt



Joined: 03 Nov 2019
Posts: 2

PostPosted: Sun Nov 03, 2019 6:15 am    Post subject: Loader no longer working using PHP 7.3 Reply with quote

Hi my ionCUbe loader no longer works. Probably this broke down after configuring PHP73 on a synology NAS using Disk Station. After downloading the last .so files and re configuring the ini for my applicaton (filerun) I can't get it to work anymore.

the wizard PHP file reports:

The following problem has been found with the ionCube Loader installation:
The loader file /usr/local/lib/php73/modules/ioncube/ioncube_loader_lin_7.3:i:.so, listed in the configuration file, /run/php-fpm/conf.d/filerun.ini, does not exist or is not accessible.

And the filerun application PHP mentions:

Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance.

Any advice on what to do to make the loaders work?
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 308

PostPosted: Tue Nov 05, 2019 10:25 am    Post subject: Reply with quote

It looks as if you have a typo in your zend_extension line as the Loader Wizard is saying that the path is:

/usr/local/lib/php73/modules/ioncube/ioncube_loader_lin_7.3:i:.so

So it looks as if there is a stray ":i" in the name of the file.

In general, the best thing to do is to create a ticket in our Support Help Desk at https://support.ioncube.com The Loader Wizard gives a link to create the ticket on its test page.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
martijnbolt



Joined: 03 Nov 2019
Posts: 2

PostPosted: Fri Nov 08, 2019 1:20 pm    Post subject: Reply with quote

ah. thank you. those pesky vi commands Smile Thanks. That solved it. Smile
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 308

PostPosted: Fri Nov 08, 2019 5:20 pm    Post subject: Reply with quote

You're welcome and I am pleased that you managed to resolve the problem.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum