ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Goto page Previous  1, 2
 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

ioncube for php 5.5

Author Message
ddleigh



Joined: 07 Jun 2007
Posts: 44

PostPosted: Wed Jan 01, 2014 11:37 pm    Post subject: Reply with quote

Are there any plans to release an Win X64 version of the loaders for PHP 5.5.

If so, can you say when they will be available, please?

Debbie
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Thu Jan 02, 2014 3:31 am    Post subject: Reply with quote

ddleigh wrote:
Are there any plans to release an Win X64 version of the loaders for PHP 5.5.


We will be releasing 64 bit Windows Loaders, however there is no planned release date currently, and this may not be before there are official builds from php.net.
_________________
Community Admin
Back to top
View user's profile Send private message
ddleigh



Joined: 07 Jun 2007
Posts: 44

PostPosted: Thu Jan 02, 2014 3:47 am    Post subject: Reply with quote

Can you announce the release with an email, so I can come and get it straight away, please?

Debbie
Back to top
View user's profile Send private message
3dweb



Joined: 09 Jan 2014
Posts: 1

PostPosted: Thu Jan 09, 2014 2:38 pm    Post subject: Reply with quote

Quote:
php was encoded by the ionCube Encoder for PHP 5 and cannot run under PHP 5.5. Please ask the provider of the script to provide a version encoded with either the ionCube Encoder for PHP 5.3 or for PHP 5.4. in Unknown on line 0


So, what must be settings in project to encode files for php 5.5? I see settings "php source language" with options:
php 5
php 5.3
php 5.4
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 351

PostPosted: Fri Jan 10, 2014 10:39 am    Post subject: Reply with quote

Quote:

Quote:

php was encoded by the ionCube Encoder for PHP 5 and cannot run under PHP 5.5. Please ask the provider of the script to provide a version encoded with either the ionCube Encoder for PHP 5.3 or for PHP 5.4. in Unknown on line 0



So, what must be settings in project to encode files for php 5.5? I see settings "php source language" with options:
php 5
php 5.3
php 5.4


You will need to select either PHP 5.3 or PHP 5.4 as the source language. Files encoded with the PHP 5 option will not run on PHP 5.5.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
guaycuru



Joined: 17 Jan 2014
Posts: 1

PostPosted: Fri Jan 17, 2014 12:43 am    Post subject: 2538 53459938 Reply with quote

Any estimatives for the PHP 5.5 loader for Windows?
PHP 5.5 has been around for more than 6 months now, and there are loaders for every other platform, but why not for win32???
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 351

PostPosted: Fri Jan 17, 2014 12:53 pm    Post subject: Reply with quote

The ionCube Loaders for PHP 5.5 on Win32 have just been released. As with the other PHP 5.5 Loaders those currently only run files encoded with either PHP 5.3 or PHP 5.4 as the source language.

To answer your question about the Windows loaders being delayed relative to other platforms, that was partly due to the need to use VC11 rather than VC9 as PHP 5.5 itself is only available from windows.php.net as a VC11 build.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
cipao



Joined: 17 Apr 2014
Posts: 1

PostPosted: Thu Apr 17, 2014 10:25 am    Post subject: Reply with quote

Hello,

i have installed newest ioncube loader but i receive nevertheless the error can any help please?

my php inof show this:
Code:
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader v4.6.0, Copyright (c) 2002-2014, by ionCube Ltd., and
    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2014, by Zend Technologies



Code:
was encoded by the ionCube Encoder for PHP 5 and cannot run under PHP 5.5.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for either PHP 5.3 or PHP 5.4 or PHP 5.5. in Unknown on line 0

My System is:
Code:
FreeBSD hexeda 10.0-RELEASE-p1
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Fri Apr 18, 2014 12:38 am    Post subject: Reply with quote

The message says what to do as follows.

"Please ask the provider of the script to provide a version encoded with the ionCube Encoder for either PHP 5.3 or PHP 5.4 or PHP 5.5. "
_________________
Community Admin
Back to top
View user's profile Send private message
factorx



Joined: 07 Jul 2017
Posts: 1

PostPosted: Fri Jul 07, 2017 8:20 pm    Post subject: Reply with quote

liaison wrote:
The message says what to do as follows.

"Please ask the provider of the script to provide a version encoded with the ionCube Encoder for either PHP 5.3 or PHP 5.4 or PHP 5.5. "



As a script user that's a serious inconvenience and a remarkably NOT well thought out execution by Ioncube. So I need to go purchase a new license for a script I already paid for because you can't make your product compatible with old versions of your encoder?

Seriously, WTF?
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Wed Aug 09, 2017 10:54 am    Post subject: Reply with quote

factorx wrote:
As a script user that's a serious inconvenience and a remarkably NOT well thought out execution by Ioncube. So I need to go purchase a new license for a script I already paid for because you can't make your product compatible with old versions of your encoder?


I have no idea whether your script provider would provide newer builds of the version of code you are using, but you replied in a thread created many years ago, and since the time when what you quoted was written we released support for running encoded files for really old versions of PHP on some newer versions.

It's actually a good job that the code you have was ionCube protected and not done so with Zend or any other tool, because ionCube is the only serious code protection tool to ever offer any backwards compatibility. It's rather difficult to run old compiled code on newer PHP releases due to incompatibilities and changes in PHP internals requiring on the fly modifications to compiled code and other fixups, but you're absolutely correct that it's important, and while the other providers seemingly never considered it necessary or managed to achieve it, we've always made it a priority; it's actually one of the many USP's that ionCube has.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum