ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube PHP Encoder

error

Author Message
sinan



Joined: 02 Mar 2006
Posts: 4

PostPosted: Thu Mar 02, 2006 1:16 am    Post subject: error Reply with quote

The file /var/www/vhosts/tasarla.net/httpdocs/defter/index.php is corrupted.


where is the problem

http://tasarla.net/defter/ioncube/ioncube-encoded-file.php

This file has been successfully decoded. ionCube Loaders are correctly installed


http://tasarla.net/defter/ioncube/ioncube-loader-helper.php
An ionCube encoded file has been loaded successfully.
Encoded files should now function correctly.
Back to top
View user's profile Send private message
ckh



Joined: 27 Mar 2005
Posts: 49

PostPosted: Thu Mar 02, 2006 8:42 am    Post subject: Reply with quote

Either the file is actually corrupted or the file has been encoded in binary format and needs to be uploaded in binary mode, not ascii.

I'm not sure if there is a way to tell or not by looking at the source. I also 'think' you can upload an ascii file in binary mode and it will be ok, if not, someone please correct me.
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Thu Mar 02, 2006 10:33 am    Post subject: Reply with quote

Hi

Good reply. The other reason is an old Loader, and that's what it is in this case. Corruption tends not to be such a common problem with the encoder products as the default file format is ASCII, so winzip and ftp issues generally don't arise.

Encoder 6.5 needs Loader version 3.1 or greater as it has new security features that are not known about by the older Loaders. Loaders < 3.0 report newer files as corrupted, which isn't strictly correct but couldn't be avoided. Loader 3.0 would say that a newer Loader was required.
_________________
Community Admin
Back to top
View user's profile Send private message
sinan



Joined: 02 Mar 2006
Posts: 4

PostPosted: Thu Mar 02, 2006 11:00 am    Post subject: ok Reply with quote

I m remove old driectory and files and uploaded inary mode with

fiezilla ftp program but not working

The file /var/www/vhosts/tasarla.net/httpdocs/defter/index.php is corrupted.
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Thu Mar 02, 2006 11:05 am    Post subject: Reply with quote

The Loader is in the php.ini file, so it needs to be replaced there. It's impossible to override a Loader in the php.ini file with runtime install, so if an old Loader is in the php.ini file it must be updated there.

Note that generally old Loaders aren't a problem, and it's only if there's a new Encoder release that introduces new features to the encoded files that cannot be made optional. In this case, new security features of 6.5 preclude older Loaders.
_________________
Community Admin
Back to top
View user's profile Send private message
sinan



Joined: 02 Mar 2006
Posts: 4

PostPosted: Thu Mar 02, 2006 11:16 am    Post subject: Reply with quote

how can I do

eg www.e-sayfa.net is ioncube encoder and running

my encode file not running


I have got root permision server is mine
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Thu Mar 02, 2006 12:22 pm    Post subject: Reply with quote

The loader helper script has a link (or menu option if in cli mode) for giving precise php.ini install instructions, so please try that. Note that if your server is not a dedicated server, the system administrator would need to effect the change.

If your server is a true dedicated server, then as you already have the Loader installed, presumably you did this at some point in the past, and you just need to update the zend_extension line in the php.ini file to point to wherever you installed the latest Loader, and then just restart Apache.

This thread has some useful and enough general information now for others having the same issue, but if you're still struggling, please create a ticket in the helpdesk so that we can help you with any other specifics to editing the php.ini file.
_________________
Community Admin
Back to top
View user's profile Send private message
sinan



Joined: 02 Mar 2006
Posts: 4

PostPosted: Thu Mar 02, 2006 10:12 pm    Post subject: Reply with quote

my php version

This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend Technologies with the ionCube PHP Loader v2.5, Copyright (c) 2002-2004, by ionCube Ltd.

is it corect or incorrect
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube PHP Encoder All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum