ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

IonCube Loader 4.7.4 does not work with PHP 5.6

Author Message
meph



Joined: 12 Feb 2015
Posts: 3

PostPosted: Thu Feb 12, 2015 10:07 pm    Post subject: IonCube Loader 4.7.4 does not work with PHP 5.6 Reply with quote

Hello!

I just downloaded ionCube loader 4.7.4.
First i had problems installing it, i wanted to do it manual first but there was hard to find a simple howto document that explained what to add to php.ini. I ran the installer which threw an error but it turned out it was the test script that came with the installer was made for php4?? After cleaning up after the installer i could continue...

anyway...

To my problem. From what i can understand the loader 4.7.4 does support PHP 5.6?
The loader comparison table only describes loader 4.6 that supports php 5.5.

When i run phpinfo the loader seems to be working.

But when i try to activate a wordpress plugin called "imember360" that needed ionCube i get the following error:

Sorry, IonCube Loader requires a PHP version between 5.2 and 5.5

So.. Do i need to downgrade to PHP 5.5?
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Fri Feb 13, 2015 1:31 am    Post subject: Reply with quote

This sounds like a deficiency in the imember360 software. The error suggests that using PHP 5.5 would work, but were it not for the check that the provider has coded, the scripts would likely work on 5.6 too. You could ask the provider for a copy without the check.
_________________
Community Admin
Back to top
View user's profile Send private message
meph



Joined: 12 Feb 2015
Posts: 3

PostPosted: Fri Feb 13, 2015 7:24 am    Post subject: Reply with quote

The provider responded with the following:

IonCube loader only supports PHP 5.6 on 32-bit systems...

So i guess im downgrading to PHP 5.5 then.. Smile
Back to top
View user's profile Send private message
meph



Joined: 12 Feb 2015
Posts: 3

PostPosted: Fri Feb 13, 2015 10:44 am    Post subject: Reply with quote

Downgraded to PHP 5.5 now and now it works fine! Smile

Thx for help!
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2788

PostPosted: Sun Feb 15, 2015 5:22 am    Post subject: Reply with quote

Great. As for 32/64 bit, the provider is probably mistaken the 64 bit builds include PHP 5.6 in all cases IIRC. Which OS are you using?
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum