ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

ionCube Forum Index

Search found 19 matches

  Topic: Detect loader version
atdev

Replies: 0
Views: 7430

PostForum: ionCube Loader   Posted: Mon Apr 28, 2014 6:30 pm   Subject: Detect loader version
With PHP 5.3+ is there a fool proof way to check that ionCube is loaded and to get the current version being run via PHP code? We know you offer/provide a debug script, but we wanted to include a sim ...
  Topic: Minimum loaders version needed?
atdev

Replies: 3
Views: 9004

PostForum: ionCube Loader   Posted: Mon Apr 21, 2014 7:28 pm   Subject: Minimum loaders version needed?
Ok, are there other minimums for 8.1, 8.2 or 8.3?
  Topic: Minimum loaders version needed?
atdev

Replies: 3
Views: 9004

PostForum: ionCube Loader   Posted: Mon Apr 21, 2014 3:41 pm   Subject: Minimum loaders version needed?
If we encode with version 8 of the encoder, what is the minimum loader version needed?

Is there perhaps a table or guide that shows these minimum versions, etc?
  Topic: Obfuscation and better protection of code
atdev

Replies: 1
Views: 5835

PostForum: ionCube PHP Encoder   Posted: Sat Feb 08, 2014 12:10 am   Subject: Obfuscation and better protection of code
We recently found a decoded version of our software online from someone who completely decoded it.

We are considering adding obfuscation to some of our encrypted files. How would this help though ...
  Topic: Minimum loader version for 8.0 encoder?
atdev

Replies: 5
Views: 11146

PostForum: ionCube PHP Encoder   Posted: Sat Aug 31, 2013 2:01 am   Subject: Minimum loader version for 8.0 encoder?
We are using the command line encoder:
ioncube_encoder53_7.0

How can we ensure backwards compatibility with PHP 5.2 and also work with PHP 5.3 and PHP 5.4? Do we have to provide different sets of ...
  Topic: Minimum loader version for 8.0 encoder?
atdev

Replies: 5
Views: 11146

PostForum: ionCube PHP Encoder   Posted: Mon Jul 29, 2013 4:22 pm   Subject: Minimum loader version for 8.0 encoder?
What is the minimum loader version needed to run files encoded with version 8.0 of the encoder? We are seeing a lot of hosts not able to run version 8.0 encoded files because cPanel does not have the ...
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Fri Jul 26, 2013 8:03 pm   Subject: [Resolved] GoDaddy Apache 2.4 issues?
It appears GoDaddy has done something to remedy this problem as it works now, but we do not have an explanation from them. We are waiting to hear back.
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Fri Jul 26, 2013 4:44 pm   Subject: [Resolved] GoDaddy Apache 2.4 issues?
We now have a test case. This code does not work when encoded on GoDaddy when the form is submitted.

<form method="POST" action="">
<input type="text" name="a" value="A default" /> ...
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Fri Jul 26, 2013 3:58 pm   Subject: [Resolved] GoDaddy Apache 2.4 issues?
Unfortunately we don't have an update today as the problem still occurs. We might have to make an immediate decision not to use ionCube as this has rendered our software useless for our clients since ...
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Fri Jul 26, 2013 2:45 am   Subject: [Resolved] GoDaddy Apache 2.4 issues?
Well we have about 6 clients all submitting tickets to GoDaddy since they won't really listen to us since we are not a client of theirs.

So far each of them are getting somewhat different answers. ...
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Thu Jul 25, 2013 10:52 pm   Subject: [Resolved] GoDaddy Apache 2.4 issues?
GoDaddy support seems to think it is mod_security causing the issue. But why would this be the case if an unencoded file works fine? Is there anything that an encoded file would do to be more likely ...
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Thu Jul 25, 2013 6:39 pm   Subject: [Resolved] GoDaddy Apache 2.4 issues?
GoDaddy instructs us to install the non-64bit loaders on their instructions in their knowledgebase.

Even when pointing out the fact that the PHPINFO shows 64bit, they still say to install the 32 bi ...
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Thu Jul 25, 2013 6:03 pm   Subject: and idrample
If it was threaded, wouldn't the non-threaded loaders fail to install?

On the PHP info page it has:
Thread Safety: disabled

Linux p3nlhg1120.shr.prod.phx3.secureserver.net 2.6.32-358.11.1.el6.n ...
  Topic: [Resolved] GoDaddy Apache 2.4 issues?
atdev

Replies: 13
Views: 18826

PostForum: ionCube PHP Encoder   Posted: Thu Jul 25, 2013 2:38 pm   Subject: [Resolved] GoDaddy Apache 2.4 issues?
All of our clients on GoDaddy are experiencing an ionCube issue. GoDaddy recently upgraded to Apache 2.4 and at the same time every single client is having the issue. Uploading the unencoded version ...
  Topic: ioncube_loader_version_information function
atdev

Replies: 1
Views: 4079

PostForum: ionCube PHP Encoder   Posted: Sat Jan 05, 2013 2:24 am   Subject: ioncube_loader_version_information function
Ok we discovered it is because of the session closing and session_start() calls in the wizard script.
 
Page 1 of 2 Goto page 1, 2  Next
All times are GMT + 1 Hour
Jump to: