ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

No ioncube for 7.1?

Author Message
fakemoth



Joined: 19 Jan 2017
Posts: 1
Location: Transylvania

PostPosted: Thu Jan 19, 2017 11:50 am    Post subject: No ioncube for 7.1? Reply with quote

I just made an account only to ask this: why do you support php 7.0 and not php 7.1 when all the RHEL/Centos/SCILinux users rely on SCL and Remy repos, and this is the supported version?
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 189

PostPosted: Fri Jan 20, 2017 9:10 am    Post subject: Reply with quote

We are working on a new Encoder and Loader for PHP 7.1. The Encoder will be part of the version 10 package. We do not have a release date for that as yet.

Producing a Loader for PHP 7.0 which could run files produced by the PHP 5.6 was a massive development task due to the sheer number of differences between PHP 5.6 and PHP 7.0 in the core of PHP. It should also be noted that one of our main competitors, Zend, has given up further development on its Zend Guard product due to the internal differences between PHP 5 and 7.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
Max-PH



Joined: 21 Jan 2017
Posts: 1
Location: US

PostPosted: Sat Jan 21, 2017 8:44 am    Post subject: Reply with quote

PHP 7.1 was released on 01 Dec 2016. We should allow ionCube some time to update the encoder/loader.
Back to top
View user's profile Send private message
francesco_tubeadvertising



Joined: 19 May 2017
Posts: 1

PostPosted: Fri May 19, 2017 1:41 pm    Post subject: Reply with quote

Any news about this?
Back to top
View user's profile Send private message
ultimateBusiness



Joined: 09 Jun 2017
Posts: 1
Location: Germany

PostPosted: Fri Jun 09, 2017 2:48 pm    Post subject: Reply with quote

Any new release-info's for the loader and the encoder?

All customers will upgrade to PHP 7.1, but can't cause the software wouldn't run anymore Wink
Back to top
View user's profile Send private message
david.steadson



Joined: 28 Jun 2017
Posts: 1

PostPosted: Wed Jun 28, 2017 10:51 am    Post subject: not working on PHP 7.0.15 either Reply with quote

Trying to run the loader on WS 2016, it failed with PHP7.1 so I rolled back to PHP 7.0.15 but says it's not supported there either? Trying to use WHMCS and it's having issues they say might be fixed by upgrading to PHP7, but ioncube isn't working Sad
Back to top
View user's profile Send private message
php71



Joined: 05 Jul 2017
Posts: 1

PostPosted: Wed Jul 05, 2017 9:24 pm    Post subject: PHP 7.1 support please! Reply with quote

Yes, please update supporting PHP 7.1!

My provider updated servers, now nothing is working anymore.
Is there a releasedate known?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum