ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

ioncube_loader_lin_5.4.so

Author Message
darkskript



Joined: 19 Nov 2011
Posts: 1

PostPosted: Sat Nov 19, 2011 11:26 am    Post subject: ioncube_loader_lin_5.4.so Reply with quote

I believe No such loader exists.. How do I downgrade?

Site error: the file /var/www/html/gamecp/index.php requires the ionCube PHP Loader ioncube_loader_lin_5.4.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.

Following error in Shell:

Cannot load the ionCube PHP Loader - it was built with configuration API220090626,NTS, whereas running engine is API220100525,NTS
Failed loading /usr/lib64/php/modules/ioncube_loader_lin_5.3.so: /usr/lib64/php/modules/ioncube_loader_lin_5.3.so: cannot open shared object file: No such file or directory
API220090626,API220100525,NTS
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2545

PostPosted: Sun Nov 20, 2011 11:44 pm    Post subject: Reply with quote

Quote from php.net re PHP 5.4

Quote:
DO NOT USE IT IN PRODUCTION!


PHP 5.4 is not released yet, and as we do not support unreleased versions of PHP, there is no Loader yet. PHP 5.4 has major changes, some visible, plus a great amount of tinkering that's invisible under the bonnet, and we would really not recommended it for use for at least 6 months after the first actual release. Using it now is very premature.

You should get your server switched to PHP 5.3.
_________________
Community Admin
Back to top
View user's profile Send private message
bazyan



Joined: 13 Mar 2012
Posts: 1

PostPosted: Tue Mar 13, 2012 9:17 pm    Post subject: Reply with quote

Quote:
PHP 5.4.0 released!
[01-Mar-2012]

The PHP development team is proud to announce the immediate availability of PHP 5.4.0. This release is a major leap forward in the 5.x series, which includes a large number of new features and bug fixes.


so now, where i can get ioncube_loader_lin_5.4.so?
Back to top
View user's profile Send private message
gencer



Joined: 05 Feb 2012
Posts: 1

PostPosted: Wed Mar 14, 2012 11:21 am    Post subject: Reply with quote

bazyan wrote:
Quote:
PHP 5.4.0 released!
[01-Mar-2012]

The PHP development team is proud to announce the immediate availability of PHP 5.4.0. This release is a major leap forward in the 5.x series, which includes a large number of new features and bug fixes.


so now, where i can get ioncube_loader_lin_5.4.so?


This is already answered by Nick.

nick wrote:
The 5.4 Loader is well on its way and we're ahead of the expected schedule with it working well with our test suite already, but we can't predict a release date and we don't publish tentative or speculative dates.

PHP 5.4 is interesting, because as well as being yet another version of the PHP language with once again changes that include the syntax of the language itself, there are substantial changes internally that only people who work with PHP internals would ever see. These amount to perhaps the biggest change to PHP internals since the introduction of PHP 4 and the first Zend Engine some 13 years ago. One of our commitments is to ensure that existing encoded files can still work when new versions of PHP are released, and while easy for minor PHP releases, there can be substantial challenges when internal changes are more major.

We'll publish a news announcement, tweet etc. when the release is ready for consumption.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum