ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Package Foundry

Can't CHMOD the root installed folder?

Author Message
macroking



Joined: 23 Sep 2007
Posts: 3

PostPosted: Sun Sep 23, 2007 4:26 am    Post subject: Can't CHMOD the root installed folder? Reply with quote

Hi there,

I've just discovered IPF and I am THRILLED so far. The one thing I've run into is, I can't seem to set the CHMOD of the actual folder I install, to 777 as I need to. I've tried the following paths for it in the IPF package permissions tab:

.
..
./
/ (won't even allow this one)

How can I acheive this? I must just be missing something simple, I'm so close!

Thanks,

Jonathan
Back to top
View user's profile Send private message
macroking



Joined: 23 Sep 2007
Posts: 3

PostPosted: Sun Sep 23, 2007 4:57 am    Post subject: Reply with quote

Got around it for now by setting default CHMOD for all folders to 777. Not ideal but it works for now... how can I specify only the main root install folder?

Jonathan
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2757

PostPosted: Sun Sep 23, 2007 7:00 am    Post subject: Reply with quote

Hi

From what you've said I suspect that this isn't possible in the current version, and generally it would be a subfolder that had elevated permissions and not the main install folder. I've added this to our product wishlist though as it should be possible, and it may get looked at soon as it is most likely easy to support, altlhough sometimes what seems like it should be easy can turn out anything but.
_________________
Community Admin
Back to top
View user's profile Send private message
macroking



Joined: 23 Sep 2007
Posts: 3

PostPosted: Sun Sep 23, 2007 9:07 am    Post subject: Reply with quote

Thanks Nick! Like I said, I've solved it for now by simply setting the folder default permissions, to 777 (which interestingly DOES affect the installed folder), and since it so happens that I have only 2 other folders in my install, both of which I ALSO want to be 777, this works out perfectly for me in this one case. Definitely a future wish list though, I often need my script's home directory to be 777.

Thanks again!

Jonathan
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Package Foundry All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum