ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

thedlleal

Author Message
abimanager



Joined: 12 Dec 2010
Posts: 8

PostPosted: Sun Dec 12, 2010 10:49 am    Post subject: thedlleal Reply with quote

hi
i am using ioncube loader on my xampp local before and it was ok.
but when i bought ioncube ver 7 and encoded a simple php file for test this error shows:

Fatal error: /test.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader. in Unknown on line 0

so i going to update loader and i change the loader from ioncube_loader_win_5.2.dll to ioncube_loader_win_5.3.dll


but when i wanna run simple test this error show:

Site error: the file \test.php requires the ionCube PHP Loader ioncube_loader_win_5.2.dll to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.

what i must do?
Back to top
View user's profile Send private message
kblessing



Joined: 31 May 2009
Posts: 241
Location: Grand Rapids, Mi

PostPosted: Sun Dec 12, 2010 12:28 pm    Post subject: toluu cold Reply with quote

Did you use the loader wizzard to find the correct loaders?

Also note I don't know which Operating system you are using, but I'm going to assume windows based on your error, right now the only loader that is compatible with ioncube encoder 7 files are 4.x+ and only Windows VC9 loaders are 4.+ right now, the VC6 loaders are 3.3.18.

So if you're not using loader version 4+ then thats why you can't load an ioncube 7 encoded project.
_________________
http://ionvz.com
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
berein



Joined: 31 Dec 2010
Posts: 2

PostPosted: Fri Dec 31, 2010 10:42 am    Post subject: Reply with quote

I have the same problem. I just purchased the Ioncube Encoder, and this is the version I got:
----
ionCube PHP 4 Encoder Version 7.0
----

But I've tried loading the VC9 version of the loaders, and it says that the VC6 version is needed. The operating system I'm using is Windows XP (32bit) with Xampp and PHP 5.3.1

Is there any way to make it work?
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2582

PostPosted: Fri Dec 31, 2010 1:19 pm    Post subject: Reply with quote

We'll be releasing VC6 4.0 Loaders in January, but in the mean time and unless you're using PHP 5.3 syntax, you could switch the GUI to legacy mode and use the VC9 3.3 Loaders for your encoded files (which encoded in legacy mode do not require the 4.0 Loaders).
_________________
Community Admin
Back to top
View user's profile Send private message
berein



Joined: 31 Dec 2010
Posts: 2

PostPosted: Fri Dec 31, 2010 1:27 pm    Post subject: Reply with quote

Sorry, I copied the output of the basic encoder script. I'm using the encoder for Mac OS X, so I have no GUI...

I use the folowing code to encrypt the scripts:
------
./ioncube_encoder5 info.php -o info2.php
------

It doesn't really matter which encoder I use, I get the same error:
------
Fatal error: The file C:\xampp\htdocs\info.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader. in Unknown on line 0
-----
Back to top
View user's profile Send private message
kblessing



Joined: 31 May 2009
Posts: 241
Location: Grand Rapids, Mi

PostPosted: Fri Dec 31, 2010 9:08 pm    Post subject: Reply with quote

berein wrote:
Sorry, I copied the output of the basic encoder script. I'm using the encoder for Mac OS X, so I have no GUI...

I use the folowing code to encrypt the scripts:
------
./ioncube_encoder5 info.php -o info2.php
------

It doesn't really matter which encoder I use, I get the same error:
------
Fatal error: The file C:\xampp\htdocs\info.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader. in Unknown on line 0
-----


If you encoded with ionCube encoder 7 on OSX, then tried to run it on OSX (especially with snow leopard where PHP is compiled as 64bit) you only have 3.x loaders, which won't load v7 encoded scripts.
_________________
http://ionvz.com
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum