ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

MAMP Install problem

Author Message
milsou



Joined: 10 Nov 2010
Posts: 1

PostPosted: Wed Nov 10, 2010 12:01 pm    Post subject: MAMP Install problem Reply with quote

Hi

I'm on a mac 10.5.8 Core2Duo and MAMP

I try to install but I have this message :

Code:
*

To use files that have been protected by the ionCube PHP Encoder, a component called the ionCube Loader must be installed.

For a local server you should install the ionCube Loader using the php.ini configuration file. (Please click here if you are not on a local server.)
Installation Instructions

   1. Download one of the following archives of Loaders for OS X x86:
          * tar.gz
          * tar.bz2
          * MS Windows installer

      Please note that the MS Windows installer version is suitable for uploading from a Windows PC to your OS X server.
   2. Put the Loader files in /usr/local/ioncube
   3. Edit the file /Library/Application Support/appsolute/MAMP PRO/conf/php.ini and before any other zend_extension lines ensure that the following is included:
      zend_extension = /usr/local/ioncube/ioncube_loader_dar_5.2.so
      Alternatively, replace your current /Library/Application Support/appsolute/MAMP PRO/conf/php.ini file with this new php.ini file.
   4. Restart the Apache server software.
   5. When the server software has restarted, click here to test the Loader.
   6. If the Loader installation failed, check the Apache error log file for errors and see our guide to Unix related errors.


I make everything... but when I restart MAMP... the instruction written in php.ini > "zend_extension = /usr/local/ioncube/ioncube_loader_dar_5.2.so" will erased automaticaly.

I can't install it... How can I do... help please.
Back to top
View user's profile Send private message
kblessing



Joined: 31 May 2009
Posts: 241
Location: Grand Rapids, Mi

PostPosted: Wed Nov 10, 2010 5:43 pm    Post subject: Reply with quote

When you install MAMP it uses a different document root as well as different php/apache location. Try running <?php phpinfo(); ?> from your mamp install to find the new php.ini or use the ionCube Loader Wizzard from the download page.

Personally I wouldn't use mamp, I would simply enable php in the built-in apache,and then install mysql with their OSX installer. that way you can just use the ~/sites folder for your stuff.
_________________
http://ionvz.com
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2516

PostPosted: Thu Nov 11, 2010 11:02 am    Post subject: Reply with quote

As the php.ini file is being recreated, this indicates that there is a master template file somewhere that should be edited. Once you have found that, you should be all set.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum