ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube PHP Encoder

Error Loader in PHP 7.0.7 and PHP Encoder gui 6.5

Author Message
abaco



Joined: 29 Dec 2016
Posts: 2

PostPosted: Thu Dec 29, 2016 11:50 am    Post subject: Error Loader in PHP 7.0.7 and PHP Encoder gui 6.5 Reply with quote

I have problems when i coded with php encoder 6.5 some scripts and run it in php 7.0.7

The error shows:

was encoded by the ionCube Encoder for PHP 5.0 and cannot run under PHP 7.0. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0

In my phpencoder i see:

GUI Version 6.5.16
Available encoders
PHP 4 Encoder 6.5.16
PHP 5 Encoder 6.5.16

In Loaders directory of the installation in windows, I only have:

ioncube_loader_win_4.1.dll
ioncube_loader_win_4.2.dll
ioncube_loader_win_4.3.dll
ioncube_loader_win_4.4.dll
ioncube_loader_win_5.0.dll
ioncube_loader_win_5.1.dll
ioncube_loader_win_5.2.dll

With date of 14/07/2009

I need to know if I need some new encoders or what I must to do.

I coded files and works with php 5.6.29 ( but dont works in php 7.0.7 )

Thanks a lot
Back to top
View user's profile Send private message Send e-mail
alastair



Joined: 23 Feb 2010
Posts: 189

PostPosted: Tue Jan 03, 2017 11:28 am    Post subject: Reply with quote

Hi,

As the error message suggests, only files encoded with the PHP 5.6 Encoder can run on PHP 7.0.

You will need to upgrade to version 9, which includes an encoder for PHP 5.6,
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
abaco



Joined: 29 Dec 2016
Posts: 2

PostPosted: Wed Jan 04, 2017 4:59 pm    Post subject: Reply with quote

Ok.

I supose that thatīs the problem, but Iīm wating for someone who confirm it.

In my version, only have posibility to compile for PHP4 and php5 ( no more php 5 versions )

Thanks!!! Wink
Back to top
View user's profile Send private message Send e-mail
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2757

PostPosted: Tue Feb 28, 2017 1:16 pm    Post subject: Reply with quote

I can confirm that using Encoder 6.5 is 100% the problem as there have been many changes to PHP internals in the 11 years since that version was released!

Security has also changed, and just as any anti virus software from 11 years ago would not be effective today, using such an old security product to protect code will not be as effective as it was back then.

You should definitely upgrade, not just because of newer PHP support, but because the security advances in version 9 are HUGE. The Dynamic Keys feature of version 9 for example allows you to encrypt parts of the compiled code without the decryption key being stored anywhere, and this is a massive advancement over protection from previous versions and all other tools.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube PHP Encoder All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum