ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader

Possible to check what version of Ioncube needed?

Author Message
robo



Joined: 26 Oct 2016
Posts: 3

PostPosted: Wed Oct 26, 2016 1:59 pm    Post subject: Possible to check what version of Ioncube needed? Reply with quote

Hi all,

Purchased a plug in encoded with ioncube that links our website (woocommerce/wordpress) with our EPOS system (epos now). Uploaded the files that were sent (in binary as instructed) however when I go to install the plug in the error is returned:

"Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance."

info.php shows that ioncube is correctly installed though: "with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.1.2, Copyright (c) 2002-2016, by ionCube Ltd."

The developers don't seem to be much help, other than suggesting that 'possibly' I need the latest version 6.0.5 but they're not sure. Unfortunately my hosts won't change this, so I'd need to pay for a different hosting package and then install ioncube myself.

I only have one php.ini file, and the only lines I can see related to ioncube are these:

zend_extension=/usr/php/56/usr/lib64/php/modules/ioncube_loader_lin.so
zend_extension=/usr/php/56/usr/lib64/php/modules/ixed.lin
zend_extension=/usr/php/56/usr/lib64/php/modules/ioncube_loader_lin.so
zend_extension=/usr/php/56/usr/lib64/php/modules/ixed.lin
zend_extension=/usr/php/56/usr/lib64/php/modules/ZendGuardLoader.so
zend_extension=/usr/php/56/usr/lib64/php/modules/opcache.so

Is there any way to check or a direction I should be looking in?

Hopefully my question makes sense as I'm a bit lost here. Thanks if anyone can give me some advice.
Back to top
View user's profile Send private message
robo



Joined: 26 Oct 2016
Posts: 3

PostPosted: Wed Oct 26, 2016 4:56 pm    Post subject: Reply with quote

I've just sent them a message to ask what version of encoder they used and will add that information here.
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2757

PostPosted: Wed Oct 26, 2016 6:20 pm    Post subject: Reply with quote

See whether you have any other php.ini files where the Loader has not been added. As you almost certainly don't need the ixed or guard Loaders, I'd comment those out, and make sure that you have an extension only added once.
_________________
Community Admin
Back to top
View user's profile Send private message
robo



Joined: 26 Oct 2016
Posts: 3

PostPosted: Thu Oct 27, 2016 11:11 am    Post subject: Reply with quote

liaison wrote:
See whether you have any other php.ini files where the Loader has not been added. As you almost certainly don't need the ixed or guard Loaders, I'd comment those out, and make sure that you have an extension only added once.


Hi Liaison, thanks. I only have one php.ini file on the server. I've commented those out and commented out the first set (the server is Bluehost and auto generates the php.ini file, so I'm not sure why it has the lines twice) so that it's not there twice.

The developer said that my version of ioncube is compatible with the plugin, and as it's Bluehost who does it, I can only assume it's installed correctly. The developer asked me to turn on enable_dll in case that helped, but still getting the same errors.
Back to top
View user's profile Send private message
alastair



Joined: 23 Feb 2010
Posts: 189

PostPosted: Thu Oct 27, 2016 5:10 pm    Post subject: Reply with quote

Hi Robo,

It would be best to create a ticket in our Support Help Desk, at http://support.ioncube.com , about this as we will then be able to go into your problem more thoroughly.

When creating the ticket it would be useful if you attached to the ticket one of the encoded files that you are trying to run.
_________________
Alastair

ionCube
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum