ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   Reply to topic    ionCube Forum Index -> ionCube PHP Encoder

Backward Compatability. Is this possible?

Author Message
AlphaKilo



Joined: 08 Mar 2014
Posts: 14

PostPosted: Thu Aug 25, 2016 7:15 pm    Post subject: Backward Compatability. Is this possible? Reply with quote

I have some customers that are running PHP 5.5 and others running PHP 5.4 on their servers.

Is it possible for ioncube to encrypt with "PHP Source Language" set to 5.6 and distribute that code to users of PHP 5.5 and earlier?

Or must the code be encrypted specifically for the version of PHP that will be executing it?
Back to top
View user's profile Send private message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2756

PostPosted: Fri Aug 26, 2016 7:50 am    Post subject: Re: Backward Compatability. Is this possible? Reply with quote

AlphaKilo wrote:
I have some customers that are running PHP 5.5 and others running PHP 5.4 on their servers.

Is it possible for ioncube to encrypt with "PHP Source Language" set to 5.6 and distribute that code to users of PHP 5.5 and earlier?

Or must the code be encrypted specifically for the version of PHP that will be executing it?


With other solution providers you can only run code on the version it was encoded for, which can be a big limitation, however we provide a range of forwards compatibility. This means, for example, that if you use version 9 to encode for PHP 5.4, files can run on PHP 5.4 up to 5.6. If you encode for PHP 5.6, files can run on PHP 5,6 and PHP 7 (with the beta Loaders). It is not possible to run code for PHP 5.6 on earlier versions of PHP though because there are features in PHP 5.6 that do not exist in earlier versions of PHP, both at the language syntax level and also with the PHP internals.

If a deployment system allows for it, we recommend having a version for the most popular latest version of PHP to get the best performance, so PHP 5.6 currently, and a legacy build for the oldest version that you choose to support, so perhaps PHP 5.4 in your case.
_________________
Community Admin
Back to top
View user's profile Send private message
AlphaKilo



Joined: 08 Mar 2014
Posts: 14

PostPosted: Sun Aug 28, 2016 11:12 pm    Post subject: Reply with quote

Sounds good, thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    ionCube Forum Index -> ionCube PHP Encoder All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum