ionCube Logo
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


 
Post new topic   This topic is locked: you cannot edit posts or make replies.    ionCube Forum Index -> ionCube Loader

Where is the ionCube Loader for PHP 5.5

Author Message
liaison
ionCube Support


Joined: 16 Dec 2004
Posts: 2757

PostPosted: Sat Oct 26, 2013 10:30 am    Post subject: Where is the ionCube Loader for PHP 5.5 Reply with quote

We've had a number of questions about the Loaders for PHP 5.5, primarily asking where they are. This is a good question, and in short, they're on their way and looking good so far.

We recognise that it may not be obvious why Loaders aren't available immediately with a new major PHP release (minor PHP revisions usually require no Loader change). As we provide all important back compatibility support for existing encoded files, a new Loader is not simply a case of rebuilding for a new version of PHP (not that this would work anyway), and we generally won't release until Loaders pass our extensive QA stage. Worse than not having a Loader and staying on PHP 5.4 for a while with a working website, would be having a Loader sooner, upgrading and then having a broken website because the existing encoded files aren't compatible, which is exactly what happens with encoded files from some other providers. We prefer to put the time into ensuring that when you upgrade, you are not taking a poisoned apple!

For us, the PHP Group tending to change both the PHP language and the way that internals are working on every release means that new Loaders are increasingly complicated, though we're normally the first provider to release Loaders, and generally around a year ahead of "The PHP Company" itself.

For end users, some package maintainers of popular Linux distributions dropping support prematurely for still live versions of PHP (which is a really bad idea and likely to cause problems for end users with non-encoded files too), means that they can be forced into unnecessary and potentially undesirable or even catastrophic upgrades to PHP.

While most users won't be pushed prematurely to a new PHP major version, in an effort to make things better for users who are or who choose to, and as we're always looking to improve anyway, we've made changes to the Loader development cycle that going forwards should generally lead to future Loaders produced earlier.
_________________
Community Admin
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    ionCube Forum Index -> ionCube Loader All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum